Estimate, job, and invoice accessibility

Incident Report for Service Fusion

Resolved

This incident has been resolved.
Posted Aug 11, 2025 - 17:19 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 11, 2025 - 16:03 CDT

Investigating

We are currently investigating reports of slow response times when accessing estimates, jobs, and invoices. We are working to identify the issue and will continue to update here as more information becomes available.
Posted Aug 11, 2025 - 15:42 CDT
This incident affected: Admin System - admin.servicefusion.com and Worker App.