DNS resolution issues for admin.servicefusion.com
Incident Report for Service Fusion
Resolved
The issue with Google DNS and admin.servicefusion.com has been fully resolved.
Posted over 1 year ago. Feb 18, 2018 - 17:17 CST
Investigating
We are currently investigating reports of some users not being able to access admin.servicefusion.com due to DNS resolution issues with their internet service providers. This issue is affecting a very small subset of users with certain ISPs.

If you are having trouble accessing admin.servicefusion.com please switch to vip2.totalfsm.com and use the same login credentials to sign in.

We will update this page again once the root cause is identified.
Posted over 1 year ago. Feb 18, 2018 - 11:38 CST