AWS has reported improvements in recovery on their end, and we are now seeing Service Fusion systems successfully navigating as expected. While functionality appears stable, our team will continue to actively monitor performance to ensure full resolution and prevent any recurrence.
Posted Oct 20, 2025 - 16:41 CDT
Update
We are continuing to monitor as AWS continues the recovery process. We will continue to update as additional information becomes available.
Posted Oct 20, 2025 - 13:28 CDT
Update
We are continuing to monitor as AWS continues the recovery process. We will continue to update as additional information becomes available.
Posted Oct 20, 2025 - 11:20 CDT
Update
We are continuing to monitor as AWS continues the recovery process. We will continue to update as additional information becomes available.
Posted Oct 20, 2025 - 09:56 CDT
Update
We are continuing to monitor as AWS continues the recovery process.
Posted Oct 20, 2025 - 08:56 CDT
Update
We are continuing to monitor as AWS continues the recovery process.
Posted Oct 20, 2025 - 07:48 CDT
Monitoring
A fix has been implemented to assist in the recovery of AWS issues from the period of 10 /19. We are monitoring the results.
Posted Oct 20, 2025 - 06:40 CDT
This incident affected: Admin System - admin.servicefusion.com, Worker App, vip1, vip2 and other *.totalfsm.com domains, QuickBooks Desktop Integration, QuickBooks Online Integration, Customer Web Portal & Customer Apps, API (beta), FusionPay, ServiceCall.ai, and GPS Fleet Tracking.