Email Deliverability Issues
Incident Report for Service Fusion
Resolved
This incident has been resolved.
Posted Sep 21, 2020 - 17:03 CDT
Investigating
We are currently investigating reports of emails not being delivered when distributed through Service Fusion.
Posted Sep 21, 2020 - 16:23 CDT
This incident affected: Admin System - admin.servicefusion.com, Worker App, and vip1, vip2 and other *.totalfsm.com domains.