Email Deliverability Issues
Incident Report for Service Fusion
Resolved
This incident has been resolved.
Posted Oct 09, 2020 - 18:40 CDT
Investigating
We are aware of an issue effecting the ability to successfully distribute email through Service Fusion. We are working with our technology partners to resolve this issue.
Posted Oct 09, 2020 - 18:11 CDT
This incident affected: Admin System - admin.servicefusion.com, Worker App, vip1, vip2 and other *.totalfsm.com domains, and Customer Web Portal & Customer Apps.