Field Worker Application for Android Devices
Incident Report for Service Fusion
Resolved
This incident has been resolved.
Posted Dec 28, 2020 - 17:30 CST
Update
We are continuing to investigate this issue.
Posted Dec 23, 2020 - 10:35 CST
Investigating
We are currently investigating reports of the Field Worker Application not appearing in the Play Store. Please contact Service Fusion support for assistance.

https://servicefusion.zendesk.com/hc/en-us/articles/360029287911-How-do-I-contact-Service-Fusion-Support-
Posted Dec 23, 2020 - 10:00 CST
This incident affected: Worker App.