ServiceCall.ai
Incident Report for Service Fusion
Resolved
This incident has been resolved.
Posted May 04, 2023 - 11:24 CDT
Monitoring
We are observing a recovery in ServiceCall.ai access and we are continuing to monitor for system stability.
Posted May 04, 2023 - 10:45 CDT
Update
Our VOIP provider has informed us that their engineering teams have been alerted and are working on the issue.
Posted May 04, 2023 - 09:42 CDT
Investigating
We are investigating reports of ServiceCall.ai inaccessibility.
Posted May 04, 2023 - 09:31 CDT
This incident affected: ServiceCall.ai.