Intermittent inability to save job changes
Incident Report for Service Fusion
Resolved
This incident has been resolved.
Posted May 16, 2024 - 13:06 CDT
Investigating
We are currently investigating this issue.
Posted May 16, 2024 - 11:08 CDT
This incident affected: Admin System - admin.servicefusion.com and Worker App.