Loading Admin Log - In

Incident Report for Service Fusion

Resolved

This incident has been resolved.
Posted Aug 03, 2026 - 13:54 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 03, 2026 - 11:42 CDT

Investigating

We are investigating reports of login failures affecting admin.servicefusion.com. Our team is working to identify and resolve the cause.
Posted Aug 03, 2026 - 10:40 CDT
This incident affected: Admin System - admin.servicefusion.com and Worker App.