Cloudfare Outage Impacting Payments

Incident Report for Service Fusion

Resolved

This incident has been confirmed as resolved.
Posted Nov 18, 2025 - 13:16 CST

Monitoring

We are aware of the global Cloudflare outage occurring today, Tuesday, November 18, 2025, which is causing service disruptions across many internet platforms, including some of Service Fusion's third-party integrations, specifically those related to payment processing for certain customers. We are monitoring the issue closely and will provide updates throughout the day.
Posted Nov 18, 2025 - 08:18 CST
This incident affected: FusionPay.