We are investigating reports of issues downloading .pdf documents across all domains.
Incident Report for Service Fusion
Resolved
This incident has been resolved.
Posted Jan 26, 2021 - 10:12 CST
Investigating
We are currently investigating this issue.
Posted Jan 26, 2021 - 09:38 CST
This incident affected: Admin System - admin.servicefusion.com and vip1, vip2 and other *.totalfsm.com domains.